Issue when accessing statistics
Incident Report for ibbu
Resolved
The problem is now solved, you can access your statistics.

Thank you for your patience.
Posted Jan 05, 2024 - 10:59 CET
Investigating
Since yesterday you may experience errors when trying to access your statistics.

Our technical team is currently working on solving this issue.
Posted Jan 05, 2024 - 09:25 CET
This incident affected: Statistics.