Service disruption - Livechat
Incident Report for ibbu
Resolved
The issue has been solved. The situation is now back to normal. Please refresh your page if you were already logged in.
Posted Apr 03, 2020 - 08:36 CEST
Investigating
The chat notification is currently not being displayed on your website. Our technical team is working on it.
Posted Apr 03, 2020 - 08:30 CEST
This incident affected: Chat and Discussion Panel.