Delay in the statistics update
Incident Report for ibbu
Resolved
This incident has been resolved.
Posted Sep 25, 2023 - 17:29 CEST
Investigating
We are currently experiencing a significant delay in updating our statistics.

As a result, you might observe that your conversation and sales data is not updating.

Please rest assured that no data has been lost, there is just a long delay in the information update.
Posted Sep 25, 2023 - 17:06 CEST
This incident affected: Statistics.