Update delay on statistics
Incident Report for ibbu
Resolved
Following a correction by our technical team, all reports are now properly updated.

Thank you.
Posted Feb 23, 2024 - 16:05 CET
Investigating
We are experiencing long update delay on our statistics service.

As a consequence your statistics data may not be up-to-date, our technical team is currently working on it
Posted Feb 23, 2024 - 14:26 CET
This incident affected: Statistics.