Statistics are temporarily unavailable
Incident Report for ibbu
Resolved
The statistics page is back !
Posted Jan 08, 2018 - 14:31 CET
Identified
We are restarting the service. This may take some time but they will be back during the afternoon. Don't worry no data has been lost.
Posted Jan 08, 2018 - 14:15 CET